Jump to content

Welcome to 205GTIDrivers.com
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
 
 

Photo

Drop Link Problem


  • Please log in to reply
5 replies to this topic

#1
flyfisher

flyfisher
  • Drivers
  • 287 posts
Joined: 17 Oct 2009
  • Location:Kent, Tunbridgewells
Garage View Garage
Hi got a problem just replacing the osf jdrop link on my 205 cti problem is on full lock the bolt head that holds lower hub to strut hits the drop link bar but only on full lock any one else had this problem many thanks

#2
Tom Fenton

Tom Fenton
  • Team Managers
  • 9,760 posts
Joined: 12 Dec 2007
  • Location:Rotherham South Yorkshire
Is this with the car jacked up and no weight on the wheel?
As it's quite common like this, but with the car on its wheels it should not foul.

#3
flyfisher

flyfisher
  • Drivers
  • 287 posts
Joined: 17 Oct 2009
  • Location:Kent, Tunbridgewells
Garage View Garage
Ok thanks

#4
welshpug

welshpug
  • Pitcrew+
  • 30,024 posts
Joined: 18 Aug 2006
  • Name:Mei
  • Location:Bridgend

have you got the bolt in the right way?  adding a washer between the droplink and the tab may help, also make sure the damper leg is located correctly.

 

but as Tom said, they are bloomin close anyway.



#5
flyfisher

flyfisher
  • Drivers
  • 287 posts
Joined: 17 Oct 2009
  • Location:Kent, Tunbridgewells
Garage View Garage
Yes bolts the same as other side I think when I checked it it was jacked up may be with weight on f/wheels it will miss ?

#6
toolie72

toolie72
  • Drivers
  • 425 posts
Joined: 06 Apr 2014
  • Name:Paul
  • Location:Inverness, Highland
Garage View Garage
I had this and put it down to shocks having the plate in the wrong place-it was the only difference

Anyway, I used a fat washer to space it back slightly
Then for piece of mind I put white insulating tape on the drop link where I thought it might touch
Ran her about and tape was unmarked-so in road running it was missing (but must be just a bahair in it)