Jump to content

Welcome to 205GTIDrivers.com
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
 
 

Photo

Hall Sensor Wiring


  • Please log in to reply
2 replies to this topic

#1
B1ack_Mi16

B1ack_Mi16
  • Pitcrew+
  • 2,775 posts
Joined: 03 Jan 2004
  • Location:Trondheim, Norway

Do some Hall sensors have some inbuilt resistors or so?

 

I've found out that the BMW hall sensor I got possibly is wired the same way as the Mi16/S16/T16 cam sensor as follows:
 

Pin 1: +12v

Pin 2: Signal

Pin 3: GND

 

Looking at youtube on testing of hall sensors I made this little circuit to test the sensors:

 

Attached File  HallWiring.gif   6.86KB   0 downloads

 

When testing on the S16/T16 cam sensor it does have 5.77volts between Signal pin and GND when there is no magnetic target in front of sensor.

It drops consistently to 0.02volts when I put a metal piece in front of sensor.

 

The BMW sensor however act more unstable.

But when first hooking it up, it shows 0.06 volts with no metal part in front of it. Putting a metal part there and it goes to 5.76v. 

However when removing the sensor from the metal it does dip to between 2-4 volts before it goes to 5.76v again... But occationally it will drop to 0.06v again when metal is removed.

 

Should the wiring possibly be different for this sensor? Can it have some inbuilt resistors etc. that makes my wiring circuit not beeing adequate for testing it?



#2
petert

petert
  • Pitcrew
  • 5,581 posts
Joined: 15 Nov 2003
  • Name:Peter Taylor
  • Location:Sydney, Australia
Your circuit does basically nothing, as the two resistors of near equal value, are tying the signal equally to earth and +12V. Remove the 5.95K completely and replace the 4.75K with something smaller, 1 to 1.5K max. This is called a pull up resistor and will hold the signal high until grounded by a vane passing the sensor.

Edited by petert, 27 March 2017 - 11:12 PM.


#3
B1ack_Mi16

B1ack_Mi16
  • Pitcrew+
  • 2,775 posts
Joined: 03 Jan 2004
  • Location:Trondheim, Norway

Ok, thanks :D I'm really retarded regarding this.

 

However it seem that the BMW sensor is supposed to be wired the same way as the Peugeot S16/T16 CAM sensor.

But the BMW one doesn't need a pull-up resistor to work, however I think it is smart to use it anyway as the voltage it delivers were small without any pull-up.

 

The BMW sensor were however much more stable when I held the sensor at an angle to the metal, no idea why, but might just be that it is due to beeing a cheap China sensor as I was just going to use it for testing anyway.